PDA

View Full Version : Stereo LED's



paulA3
July 6th, 2004, 03:32 PM
Had a few LED lights blow in my stereo (original equipment). As I wanted to keep the standard trim, the only solution Audi recommened was to purchase a new factory head unit at $400 plus. A few wrecking yards had them for $250 plus. I contacted Eurovox in VIC and they gave me a few contacts that distribute their product. Had all LED's (approx 6) replaced by S & I car audio at Brookvale NSW, at a cost of $60. They did a great job and I highly recommend them if you have the same issue.

XXX-1.8T
July 6th, 2004, 03:50 PM
thats very good information Paul saves people going out and buying a new HU :D

Haysey
July 7th, 2004, 03:43 PM
Nice work.. they will always try to sell u a new one rather then fix it...
I reckon have a go fixing it and if u fix it then its a bonus... or pay someone else to fix it.. i have many mates in car audio..
MR AUDI

Carlos
July 11th, 2004, 04:46 PM
Had a few LED lights blow in my stereo (original equipment). As I wanted to keep the standard trim, the only solution Audi recommened was to purchase a new factory head unit at $400 plus. A few wrecking yards had them for $250 plus. I contacted Eurovox in VIC and they gave me a few contacts that distribute their product. Had all LED's (approx 6) replaced by S & I car audio at Brookvale NSW, at a cost of $60. They did a great job and I highly recommend them if you have the same issue.

Same thing happened to me

The light for the 3/4 button is buggered

Thanks for the info dude