Results 1 to 10 of 10

Thread: Mk2 TT brake lights

  1. #1

    Default Mk2 TT brake lights

    Hi guys,
    might as well post here too

    The right brake light, the outside bulb keeps going out
    I've checked the bulbs twice and they are still fine and i just swapped one bulb with the other. They all light up and the right hand bulb goes out.

    anyone have any idea how to go about fixing this?

  2. #2

    Default

    could be alota things
    bad connection somewhere, but id assume both lights are on the same circuit off the same relay ?

  3. #3

    Default

    It was a common fault when I had mine. the problem is the connector. You need to remove the light cluster and disconnect it. You will notice burn marks to the pins. I cleaned mine with fine emery, lubricate and protect with electrical insulating compound (http://www.dowcorning.com/applicatio...?prod=01903128) and that should resolve your problem

  4. #4

    Default

    Ye I've just taken it out and the main power pin had a bit of black crap on it so I've given it a bit of a clean but now when I plug it in I don't think that globe turns on at all. I suppose I'll just keep cleaning and trying

  5. #5

    Default

    Quote Originally Posted by TYR382 View Post
    could be alota things
    bad connection somewhere, but id assume both lights are on the same circuit off the same relay ?
    Well that's what I'm thinking but where do you begin. What I don't understand is why they all light up and then the outer brake light goes out

  6. #6

    Default

    this is caused by the earth pin
    taking too much electrical load, due to a bizarre design flaw.
    either replace the entire light cluster if the damage is too severe. otherwise,
    there’s a DIY write up on the ttuk forum on how to wire anadditional grounding wire or something. I just got my workshop to do it as theyhave done this fix before


  7. #7

    Default

    Ye I found a pretty good 8min video from some guy in the UK.
    looks fairly straight forward, might head down to jaycar tomorrow and pick up some pieces to make the extra grounding cable
    its a prick of a thing, did you do both your brake lights junn?

  8. #8

    Default

    Yeap, though they both died at different times. It is veryannoying, but if you have a reliable VAG workshop, they should be able to fixit in under 30 minutes
    How’s your TT going? Any mods recently?


  9. #9

    Default

    I've done one so far and all is good
    the cars going good. The headlights are really starting to annoy me. They're just not bright enough. Just bought some led globes so I'm going to give them a go
    other then that the only recent mods are R8 ignition colis and DV+ diverter valve
    still in the market for an intake and maybe catback
    how's yours going?

  10. #10

    Default

    For those of you playing along at home
    https://m.youtube.com/watch?v=Ic7kqyKrQa0
    this is how it's done. Very helpful

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •