Results 1 to 3 of 3

Thread: 2010 RS6 C6 gearbox issues

  1. #1

    Red face 2010 RS6 C6 gearbox issues

    Hi fantastic team!

    I recently purchased this beautiful beast but it hasn't all been smooth sailing unfortunately.

    I have had to replace a few fuel injectors and have the carbon scraped out of the valves at the same time. This was after some random misfires and replacing spark plugs which didn't fix it (although it was OK for a while) and it seems to be OK now.

    I have random issues with doors not unlocking and also the rear tailgate button intermittently not working to close it.

    But the biggest concern is the gearbox. At low speeds it makes the odd clunking noise which sounds like it's as the gear is being selected. Then on occasions if you accelerate then back off then accelerate again it doesn't change gear say from 3 to 4. It hen pops up a gearbox error message and says you can continue to drive but with limited function and it won't change up gears. If I stop and turn it off and go again, the message clears and the issue goes away. On one occasions it was doing a lot of the clunking noise and not changing well between gears and then there was a noise like there was a loose rock in the gearbox. Once again, turned off and restarted and it went away.

    Most of the time it's OK apart from the odd clunking noise at low speed. Should I get Audi to look at it to prevent any further damage or just go until it craps itself and get it reconditioned? Could it be something simple or am I looking at the usual insertion of Audi pineapple for anything to do with the RS6?

    Any ideas?

    Cheers,


    Nic
    Attached Images Attached Images

  2. #2
    Join Date
    Feb 2005
    Location
    Melbourne
    Posts
    9,541
    Thanked: 415

    Default

    Congrats on the car Nic - looks like a clean example.

    Do you know what the fault code is associated with the gearbox issue?

    In terms of the door lock issue, I’ve got a brand new in box original door lock regulator for the 4F. Let me know if you would like to buy it - will be a fraction of dealer price.

  3. #3

    Default

    Would definitely start with reading the fault codes.

    E clutch controls gears 4,5,6 so sounds like you might have a fault with that or the solenoid in the mechatronic that controls it.

    Check the fluid level as well - some people employ the 'fill to spill' method on this box, forgetting that the engine needs to be running and gearbox oil temperature at approx 35c to get the level right.
    MAY THE 4'S BE WITH YOU
    2011 Audi A6 3.0T S-Line Phantom Black/2-tone Valcona, Bose 112K
    2008 Range Rover Sport TDV6 white/black leather, 20ís, h/k 307K
    2001 Audi A4 1.8TQ GP Sport, Ming Blue/slate 370K
    1990 Nissan Pintara TRX 5MT, a few mods 439K!!

    Gone but not forgotten
    2000 Audi S4 6MT, nogaro/black Stage 3-
    1999 Audi A4 1.8TQ GP Sport Avant 5MT, black/black/walnut

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •