Results 1 to 2 of 2

Thread: TPMS+Transmission malfunction

  1. Unhappy TPMS+Transmission malfunction

    Hello Guys,

    I got a Audi A4 2014 Sedan 2.0 TFSI quattro B8 and it has 88K on the clock. I started getting TPMS malfunction and Transmission malfunction (no reverse+even gears not working) indicators last week . Don't exactly know what is causing the issue coz my appointment with the transmission mechanic is a week away.

    Is any of you guys had slimier issue before?
    Do you have any suggestion what could be the issue?
    Any good mechanic to go to near Sydney/Canberra area?

    Thanks,
    JSB

  2. #2

    Default

    That sounds like the mechatronic unit for the DSG gearbox. ouch! $7000 repair. ATA in Alexandria are good but when you replace the unit it has to be coded by Audi. If you've had the car serviced by Audi they may give you a discount as a gearbox should last at least 100,000ks. I'd recommend having the car towed as you don't want to fix the controller to find that you burnt one or two of the clutches out driving while faulty.
    1997 A3 1.8T sold
    2000 TT quattro sold
    2005 Lava Grey A3 2.0 TFSI DSG Sportback, Open Sky, roof racks, Vienna Leather. Sold
    2006 Black A4 2.0 TFSI S-line Quattro Avant Sold
    2009 White A4 2.0 TFSI Quattro Avant, Open Sky roof, MMi+ 19" rims, Bang and Olufsen, adaptive cruse, Oak Beaufort trim. Sold
    2016 A4 Quattro sport Avant, Manhattan Gray, Panno roof, Technik package, Assistance package. Sold
    2018 S4 Avant, Sports diff, S performance package, Technik package, honeycomb grille, Nardo Grey Wrap.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •