Results 1 to 4 of 4

Thread: RS mode intermittent - RS5 2020 model

  1. #1

    Question RS mode intermittent - RS5 2020 model

    Hi Everyone,

    First time posting, not sure if I have put this in the correct place - apologies if not.
    I bought an ex demo RS5 in January 2021 and have experienced the same issue since day 1.
    I have RS1 and RS2 settings both set up to Dynamic everything etc. When I turn the car on it
    will be in Auto, and I then switch to RS mode via the steering wheel. This is where there is
    inconsistency. Sometimes it will work as expected, sometimes nothing changes and I have to cycle
    through RS1, RS2, auto a few times before it kicks in.
    There is a noticeable change in engine note and revs when it works as expected, so quite obvious when
    it doesn't change. Although sometimes I just drive off and don't really notice until I try to accelerate hard
    and it feels like I am pushing on a pedal that is restricted.
    It doesn't happen all the time, but happens at least 4-5 times per week.

    I have had car serviced and get the usual "there is no error code so we cant do anything" nonsense from them.

    Very frustrating to have this happening every single week.

    I am not technically gifted when it comes to cars so excuse my ignorance in any future conversations.
    Appreciate any insights anyone has.
    Cheers.

  2. #2
    Join Date
    Feb 2005
    Location
    Melbourne
    Posts
    10,078
    Thanked: 477

    Default

    I wonder if there is a software update available for the relevant module (Body Control Module or BCM) that controls functions such as this.

    Not sure where you are located (can I suggest updating your profile with your city/location) but it might be worth chatting to a different dealer about the issue and seeing if they might be more helpful with taking some additional troubleshooting steps.

    If you're in Melbourne I can recommend a dealer service contact for you.

  3. #3

    Default

    Hi Alister,

    Yes I am in Melbourne, sorry I will update profile shortly. (Just joined).
    I did ask this same question at last service and they said they would check for updates, but nothing was done as far as I know.
    I also requested they do a "hard reset" if that is the correct term, but pretty sure they did nothing....

    I purchased a service package from them when I bought the car, and get the feeling they don't want to do much as the package
    is obviously quite sharply priced.

    Would love to speak to someone else about it if you have a contact you can pass on.
    Appreciate your time.

  4. #4
    Join Date
    Feb 2005
    Location
    Melbourne
    Posts
    10,078
    Thanked: 477

    Default

    Have sent you a PM Charlie - let me know how you get on.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •